Autor Tema: Nvidia ShadowPlay no graba audio  (Leído 10996 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ThaReP

  • ¡Fuerza y Honor!
  • General de división
  • Zero
  • Mensajes: 14087
  • Sexo: Masculino
  • (づ ̄ з ̄)づ
    • Ver Perfil
    • ThaReP Youtube
Nvidia ShadowPlay no graba audio
« en: Noviembre 10, 2014, 12:32:50 pm »
Muy buenas, no sé si habrá mas gente aquí en el foro que usen la herramienta de ShadowPlay.

Y vengo mas que con una duda con la intención simplemente de saber si lo que me está pasando le pasa a mas gente que lo use o no.

A mi el ShadowPlay me ha ido perfecto hasta hace un par de días, cuando grabé un Gameplay y al ir a verlo vi que el audio del juego no se había grabado, volví a probar y lo mismo, reinicié el SO y si que lo grababa, asumí pues que fue algo ocasional y que lo habría provocado quizás el Nvidia Inspector, el cual había usado para hacer funcionar otro videojuego.

La cosa es que hoy he ido a grabar otro videojuego diferente, por si acaso he hecho una prueba y he grabado un cacho pequeño, me lo ha grabado con audio del juego incluído que es lo que quería, mas tranquilo me he puesto a grabar una hora entera, al salir me topo con que, nuevamente no me ha grabado el audio del juego, he reiniciado el SO nuevamente y he vuelto a hacer pruebas; indistintamente o dicho de otra forma, cuando le ha dado por ahí si que lo ha grabado y cuando no... no.

Me jode cuando algo pasa así, preferiría que directamente no funcionara nunca a que a veces vaya a ir bien y otras no y dependa del puro azar.

Actualicé los Drivers hace poco, no sé si tendrá que ver (344.60), aunque el problema de que no me grabara el audio estoy casi seguro que me pasó antes de actualizar.

Edit: Mirando por internet no veo nada de nada al respecto, creo que jugaré al Stubbs the Zombie, que es el juego para el que tengo que usar el Nvidia Inspector, tras ello lo eliminaré, pasaré cleaner y reinstalaré Drivers y a ver si hay suerte con eso, aunque dudo que sea cosa del Nvidia Inspector, ya que no esta ni instalado siquiera pero bueno, nunca se sabe.

Citar
Do you have Desktop Capture enabled? I used to use it for a while, but an update broke it somewhat. A lot of my recordings would have no audio exceot for my mic. Disabling Desktop Recording fixed it for me.
Me he topado con esto y yo también lo había pensado, hace cosa de semanas, para poder grabar el audio In-Game y el micro por separado se me ocurrió que empezaría las grabaciones desde el escritorio y al mismo tiempo iniciaría una grabación de sonido con el grabador de sonidos de Windows para el micro, pero no se, esto me está pasando con las 2 últimas grabaciones, en las 4 anterioes no ha habido ningún problema y también las inicié desde el escritorio, pero bueno, es una posibilidad, otro rato haré grabaciones con ShadowPlay con la grabación del escritorio desactivada y a ver que tal.

Pero que coño, ahora que pienso, todo mis tutos están hechos con la grabación del escritorio como es obvio y ahí no he tenido problemas nunca.

Acabo de probar a entrar a un juego e iniciar desde ahí la grabación, con la grabación de escritorio desactivada, he repetido el proceso 10 veces y las 10 veces se me ha grabado el audio del juego, parece bastante claro que era por esto, o no xD ya que como digo falla cuando le da por ahí, pero bueno, es lo que es mas probable que sea, si fuera esto por una parte es un alivio porque ya sabría porque es, por otra parte es una faena porque si inicio la grabación del micro con la grabadora de Windows antes de meterme al juego y luego una vez en el juego grabo con el ShadowPlay luego tengo que sincronizar los audios xD.
« última modificación: Noviembre 10, 2014, 02:18:56 pm por ThaReP »

ThreeDog

  • Magical Girl
  • Mensajes: 3655
  • Sexo: Masculino
  • C3RB3RO
    • Ver Perfil
    • Radio Galaxia
Re:Nvidia ShadowPlay no graba audio
« Respuesta #1 en: Noviembre 10, 2014, 02:39:21 pm »
A mi me funciona perfectamente, claro que, al igual que tu ahora, tengo la grabación de escritorio desactivada. Puedes grabar el audio del micro con el propio shadowplay, aunque claro, se mezclan las pistas de audio en una sola.
Un consejo para sincronizar un audio, en caso de que quieras hacerlo así: haz un sonido (como una palmada o algo) al mismo tiempo que realizas una acción con tu personaje en el juego (como disparar o saltar o algo). Luego, cuando tengas que sincronizar los audios puedes usar eso como referencia, con lo cual, te será mucho más sencillo. O eso hago yo y me resulta sencillo xDD

ThaReP

  • ¡Fuerza y Honor!
  • General de división
  • Zero
  • Mensajes: 14087
  • Sexo: Masculino
  • (づ ̄ з ̄)づ
    • Ver Perfil
    • ThaReP Youtube
Re:Nvidia ShadowPlay no graba audio
« Respuesta #2 en: Noviembre 10, 2014, 02:54:27 pm »
Si, eso que dices es mas o menos lo que hice al grabar esto:
https://www.youtube.com/watch?v=rx_IuOSLJdU&list=UUCMx-wL-2QhYllpCU7YtGPw

Y ya los vídeos siguientes los hice como digo iniciando ambas grabaciones a la vez (ShadowPlay y Grabador de Sonidos)

Bueno, al menos he encontrado una forma de asegurarme si cuando vaya a hacer la grabación se grabará el audio o no, dicho de otra forma, puede que no se grabe el sonido, pero lo sabré antes de tirarme una hora jugando y ya será cosa de cancelar y repetir hasta que funcione
http://puu.sh/cKXXS.jpg

La cosa consiste en que iniciaré la grabación tanto de micro como de ShadowPlay desde el escritorio y lanzaré el juego, Si el Nvida Capture Server no tiene nivel de sonido a cerrar el juego ya antes que lo lance y a volver a probar, si si que se observa que hay "barrita verde" la cosa promete xD, una vez dentro del juego ALT + TAB para ir al escritorio y confirmar que todo sigue correcto, y ya palante.

Pff, igual es menos rollo y todo lo que tu dices Paco xD
« última modificación: Noviembre 10, 2014, 03:10:29 pm por ThaReP »