Autor Tema: Error al abrir MP4 tanto con Sony Vegas Pro como con Aegisub.  (Leído 2681 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Koke

  • Alquimista nacional
  • Magical Girl
  • Mensajes: 3440
  • Sexo: Masculino
    • Ver Perfil
Hola a todos.

Estoy iniciandome en la edicion de video. Con el mkvextract gui consigo separar el archivo H264 de un MKV. Hasta aqui sin problema.

Con el MP4BOX gui o el YAMB convierto este archivo H264 en MP4.

El problema lo tengo a la hora de abrir este archivo MP4 con el Sony Vegas Pro, que me indica siempre que el programa dejo de funcionar.

He probado a abrir archivos MP4 descargados de esta web con el Sony Vegas y no tengo ese problema, por lo que deduzco que el problema debe estar el la conversion de H264 a MP4 que hace el MP4BOX.

Si alguien sabe donde puede estar el problema le estaria muy agradecido.

EDITO: Esto me pasa con el H264 de Naruto Shippuden (he probado varios por ejemplo el capitulo 204). Con el H264 del capitulo Fairy Tail 79 no me pasa. Son diferentes personas las que realizan el ENCODE, a ver si me haceis ver la luz xD.

EDITO2: Con el H264 de Ano Hi Mita Hana no Namae wo Bokutachi wa Mada Shiranai Capítulo 5 tampoco tengo problema. Parece ser que el problema es unicamente con Naruto Shippuden.

EDITO3: El Aegisub me da este error al intentar abrir el MP4 conflictivo:



Sin embargo, si intento abrir directamente el MKV de donde he extraido el H264 conflictivo no me da problemas.

P.D: Si quereis informacion de ambos H264 (el que me da problemas y otro que no) os hago una capturas de lo que me dice el MediaInfo GUI.

Un saludo.

« última modificación: Mayo 21, 2011, 11:16:31 pm por Koke »

Batousay

  • ^_^
  • Capitán General
  • Battosai el asesino
  • Mensajes: 4351
  • Sexo: Masculino
    • Ver Perfil
    • Batousay - De todo un poco
Re:Error al abrir MP4 tanto con Sony Vegas Pro como con Aegisub.
« Respuesta #1 en: Mayo 22, 2011, 08:01:46 pm »
Hola, siento no poder ayudarte, pero no tengo ni idea de porqué te falla.

Quiero decir, en mi caso simplemente comprimo siguiendo el estandar, nivel 4.1 para que funcione con CUDA/DXVA y los reproductores de sobremesa y poco más...

A mi parecer tiene pinta de ser algún problema del muxer de MP4, pero no te lo puedo asegurar.

Saludos.

Gin

  • Nightwalker
  • Capitán General
  • Zero
  • Mensajes: 14462
  • Sexo: Masculino
  • No guts, no glory
    • Ver Perfil
    • Night Walks
Re:Error al abrir MP4 tanto con Sony Vegas Pro como con Aegisub.
« Respuesta #2 en: Mayo 22, 2011, 09:43:13 pm »
¿Esos kanjis de donde salen? ¿Se los pones tú, Koke?

Koke

  • Alquimista nacional
  • Magical Girl
  • Mensajes: 3440
  • Sexo: Masculino
    • Ver Perfil
Re:Error al abrir MP4 tanto con Sony Vegas Pro como con Aegisub.
« Respuesta #3 en: Mayo 23, 2011, 12:18:02 am »
Los Kanjis de la imagen dices? No, eso se genera automaticamente.

Como dije este error unicamente me pasa con los capis de Naruto de este fansub. Con MKV's de naruto de otro fansub y otras series de este fansub no me ocurre.

Por cierto para editar un archivo H264 para poder incluirle subtitulos, filtros, etc, con que programa lo hago?

Saludos!
« última modificación: Mayo 23, 2011, 12:33:15 am por Koke »

Lucas

  • Antiguo Staff
  • Teniente General
  • Mensajes: 1549
  • Sexo: Masculino
  • 「Against Father」
    • Ver Perfil
Re:Error al abrir MP4 tanto con Sony Vegas Pro como con Aegisub.
« Respuesta #4 en: Mayo 23, 2011, 12:33:21 am »
Si el nombre del archivo tiene kanjis puede ser una firme razón por la que el aegisub no te lo abra, si es así cambia el nombre a algo como "asda", y proba, xD

Koke

  • Alquimista nacional
  • Magical Girl
  • Mensajes: 3440
  • Sexo: Masculino
    • Ver Perfil
Re:Error al abrir MP4 tanto con Sony Vegas Pro como con Aegisub.
« Respuesta #5 en: Mayo 23, 2011, 01:11:25 am »
Los archivos son del tipo NS204.mp4. Lo de los kanjis no es cosa mia.

Saludos!